Search This Blog

Loading...

Monday, July 25, 2011

Joomla - Re: JAuthentication::__construct: Could not load authentication libraries

I disabled the plugin - Authentication – Joomla as I thought it was for user logging in the page, not the admin login. It was a big mistake though. To turn this feature on you need to log to Joomla’s database and change published to 1 in the jos_plugins table  in row.Name = Authentication – Joomla (it was row.id = 1 in my case).

UPDATE `your_database_name`.`jos_plugins` SET `published` = '1' WHERE `jos_plugins`.`id` =1;

25 comments:

  1. JAuthentication::__construct: Could not load authentication libraries

    It may happen that you try to login to Joomla Admin and you get following error

    The following error is displayed.

    * JAuthentication::__construct: Could not load authentication libraries.
    * Username and password do not match

    The error occurs when you inadvertently disable the plugin “Authentication – Joomla” assuming it was for the front-end authentication. This plugin is for the admin authentication and no one would want to disable this.
    Authentication Plugin - Joomla Admin

    Authentication Plugin - Joomla Admin

    All you need to do is access the Joomla database through Phpmyadmin, look for “jos_plugins” table and change it’s field ‘published status’ to 1 .
    Authentication Plugin - Phpmyadmin

    Authentication Plugin - Phpmyadmin

    ReplyDelete
  2. Great information.Great thoughts.It is very important to know all the people.It is great and happy to read this blogs.Thanks for making it.

    ReplyDelete
  3. Cannot find any Authentication Plugin - Joomla Admin
    in PhpMyAdmin
    im using Joomla 2.5

    ReplyDelete
  4. Try to set plg_authentication_joomla in the table extensions, to enabled=1 (joomla 2.5.2)

    ReplyDelete
  5. Hi to all.
    I have same issue, Joomla 2.5
    plg_authentication_joomla is set to 1

    and i still have
    "JAuthentication: :__construct: Could not load authentication libraries." error, what can i change to fix it?

    ReplyDelete
  6. Sloved.
    Data base stuck, and it`s take some time to apply change.

    ReplyDelete
  7. hi, I'm using Joomla 2.5.3

    cannot find the plg_authentication_joomla.

    ReplyDelete
  8. Me to, I use Joomla 2.5.4.

    ReplyDelete
  9. Go to:
    phpMyAdmin

    Find "Extantions" table.
    In extantions table, go to page 3 or 4, and find there "plg_authentication_joomla" - enaible it from 0 to 1.

    ReplyDelete
    Replies
    1. this is the most useful help i have ever mate on blog..... Thank youuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuu

      Delete
  10. infiniment merci !!!! YOOOO

    ReplyDelete
  11. i enabled "plg_authentication_joomla" - from 0 to 1
    but still nothing happens.
    Now,neither showing error nor authenticating.
    Please help
    Thanks in Advance.

    ReplyDelete
  12. @ Neeraj

    follow the comment #20
    http://www.wincert.net/tips/joomla/2582-joomla-admin-locked-out-jauthenticationconstruct-could-not-load-authentication-libraries.html

    ReplyDelete
    Replies
    1. Thanks so much - this reply helped

      Delete
    2. in joomla 2.5.7,
      Enable
      plg_user_joomla and plg_authentication_joomla

      from table jos_extension

      Delete
    3. Thanks, you saved me a lot of time.
      Both need to be enabled!

      Delete
  13. I received same error.. I'll try what I found on this blog.. Thanks

    ReplyDelete
  14. For me the following solution works: plg_authentication_joomla in the table extensions, to enabled=1

    ReplyDelete
  15. Thanks a lot. Helpful blog

    ReplyDelete
  16. Thanks you so much guys.... Great work

    ReplyDelete
  17. My problem was solved and I just had to change access from 0 to 1:
    find this record and change the bold items to these values:
    extension_id 401
    name plg_authenticat ion_joomla
    enabled 1
    access 1
    protected 1

    ReplyDelete

If you like this post, please leave a comment :)