Search This Blog

Sunday, January 12, 2014

Ubuntu 12.04 - TeamViewer 8 / TeamViewer 9 - no sound/no microphone. Sound problems

TeamViewer 8 run in Wine so if there is no sound - it's probably wine's configuration fault. In my case I had a standard Intel's integrated sound card in Lenovo Workstation.

To resolve the issue, install wine 1.4 and then configure teamviewer's wine settings:

sudo apt-get install wine1.4

and then:

WINEPREFIX=$HOME/.config/teamviewer8 winecfg


For more details go to:

Configuration:



THE PROCEDURE DOES NOT WORK FOR TEAMVIEWER 9,
On Ubuntu 12.04 I tried:

  • removing puleaudio package
  • installing wine1.6 instead wine1.4 (teamviewer9 runs on wine1.6)

sudo apt-get purge pulseaudio

WINEPREFIX=$HOME/.config/teamviewer9 winecfg

$ sudo add-apt-repository ppa:ubuntu-wine/ppa
$ sudo apt-get update
$ sudo apt-get install wine1.6
$ sudo apt-get install winetricks

12 comments:

  1. So if I remove pulseaudio, my sound card still will get detected?
    does this thing work properly for teamviewer?

    ReplyDelete
    Replies
    1. Yeah, It worked for me. PulseAudio is just the part responsible for audio settings not the whole sound.

      Delete
    2. Alright, Thanku. :/ But when i purge - removed pulseaudio and ninstalled wine1.6,
      even then , in the config settings, it showed selected driver : winepulse.drv

      And i get only two options :
      (system default) and
      pulseaudio

      I dont know how that's possible even after I had purged pulseaudio

      Delete
  2. I'm referring to ubuntu 12.04 and TeamViewer 9 btw :(

    ReplyDelete
    Replies
    1. In TeamViewer9 sound DID not work for me. I used TeamViewer8 on purpose beacuse of this bug.

      Delete
  3. I finally managed to get the sound working with the above command but I had to copy winepulse.drv.so and winealsa.drv.so from the wine package to /opt/teamviewer9/tv_bin/wine/lib/wine first.

    ReplyDelete
    Replies
    1. This trick worked for me. I had to upgrade my Ubuntu version from wine 1.4 to wine 1.6 but then I got the winepulse.drv.so from /usr/lib/i386-linux-gnu/wine/ and copied it over. Then as long as the winecfg was set properly to pulseaudio via the Audio tab in:
      WINEPREFIX=$HOME/.config/teamviewer10 winecfg

      Everything worked.

      Delete
  4. The trick from Anonymous @ April 9, 2014 at 11:53 AM worked for me too. I have Ubuntu 12.04 and TeamViewer 9 too and the sound wasn working, but after copying winepulse.drv.so and winealsa.drv.so over it works like it used to. So, in my case:
    sudo cp /opt/wine-compholio/lib/wine/winepulse.drv.so /opt/teamviewer9/tv_bin/wine/lib/wine
    sudo cp /opt/wine-compholio/lib/wine/winealsa.drv.so /opt/teamviewer9/tv_bin/wine/lib/wine

    Another annoyance for me is the chat window: as you type more text into the chat window, the cursor is displayed further and further off its real position, making it hard to see. Perhaps it's a font issue of some sort.

    ReplyDelete

If you like this post, please leave a comment :)